viernes, 22 de julio de 2011

MIKROTIK: Script para usar el No-IP para MTK

Saludos a todos, seguimos con el NoIP aca les traigo un script hecho por mi buen amigo “El Pibe” para no tener usar una computadora corriendo el NoIP como servicio.

El funcionamiento es muy sencillo, lo que hace el script es conectarse a la pagina de NoIP como si nosotros entramos a la pagina vía Web para actualizar la dirección IP, luego de hacer el script tenemos que cargarlo en el “Schedule” así le podemos configurar el tiempo de activación del script para que se actualice la dirección.

Script:

:log info "NO-IP"
:global ddnslastip
:global ddnsipcn
:global ddnsip
:global str
:set ddnsipcn [ /ip address get [/ip address find interface=(interfaz por donde sale a internet ej. “pppoe-out1”) ] address ]
:for i from=( [:len $ddnsipcn] - 1) to=0 do={ 
        :if ( [:pick $ddnsipcn $i] = "/") do={ 
               :set ddnsip [:pick $ddnsipcn 0 $i]
        } 
}
:if ($ddnsip != $ddnslastip) do={
:log info "Enviando actualizacion no-ip"
:set str "/nic/update?hostname=(nombre de l host  ej. tito.sytes.net)&myip=$ddnsip"
    /tool fetch address=dynupdate.no-ip.com src-path=$str mode=http user=(usuario del No-IP ej. tito@tito.com) password=(password del servicio) dst-path=noip
:delay 1
        /file remove noip
:set ddnslastip $ddnsip
} else={
:log info " No es necesario actualizar"
}

Uds. tienen que cambiar lo que esta entre paréntesis (inclusive los paréntesis) y en letra Arial .

Aca vemos como se carga el script en el MKT

Luego de haber hecho el script tenemos que general un Schedule para que se actualice constantemente cada cierto tiempo que nosotros le especificamos, en nuestro caso le indicamos cada una hora.

Para finalizar le quiero dar las gracias al Pibe por haberme enviado el script

Espero que les haya servido.

Saludos

Hasta la proxima.

Lolo.

P.D. Dale Chavon colabora con algo con Cisco

3 comentarios:

  1. LOLLLLL !!! gracias bro ! muchas gracias

    ResponderEliminar
  2. Estimado buenos dias, tengo un problemita que necesito resolver y necesito de ayuda de expertos, mira tengo la interface 1 y 2 en el mikrotik, yo necesito desactivar la 2 y que cuando se caiga la 1 que active la 2 y viceversa , sabes de algun script para hacer esto.
    gracias

    ResponderEliminar
  3. buenos dias, ...lolo , ya configure too como dices, pero no me actualiza el ip dinamico de no-ip, se pierde la coneccion cuando reinicio mi modem, espero tu respuesta gracias..

    ResponderEliminar